Back to overview
Resolved

Discord Server Updates!

May 6, 2026 at 9:37pm UTC
Affected services
MStudios Main Website
MegaCore Dashboard

Resolved
May 6, 2026 at 9:37pm UTC

We have idetified some embed issues and have already taken action by resolving the situation furthermore our new website is live!